Products

Skincare Assessment kit

BSC711/59

Frequently Asked Questions

Which phones and systems are compatible with the Philips Skincare App?

It is important that your smart device meets the requirements of the Philips Skincare App. Find out which phones and systems are compatible with the Philips Skincare App.

Compatibility of the Philips Skincare App

Devices
The Philips Skincare App is supported by the following devices: iPhone 5S or higher. Please note that the Philips Skincare App is not yet supported by Android.

System
The device has to run on iOS 9.0 or higher.

The information on this page applies to the following models: BSC711/59 .

Not what you are looking for?

Did we answer your question?

If not, contact us.