1
0

Shopping cart

There are currently no items in your shopping cart.

    Philips Support

    What mobile devices and operating systems is the app compatible with?

    Published on 2017-07-21

    The Philips health app is compatible with iOS versions 9.3+ and Android 4.4 KitKat+. For a full overview of all compatible devices, go here.

    Looking for something else?

    Discover all Philips Support options

    Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.