1
0

Shopping cart

There are currently no items in your shopping cart.

    Philips Support

    What versions of ID3 are supported by my Philips player?

    Updated on 2017-02-28

    It supports both ID3 version 2.3 and ID3 version 2.4 tags.

    However, ID3 version 2 tags with unsynchronization scheme or UTF8 encoding will not be supported.

    The information on this page applies to the following models: SA1VBE04KM/37 , SA2VBE04KC/37 , SA2VBE04KC/17 , SA2VBE08SC/17 , SA2VBE08KC/17 , SA2VBE04WC/17 , SA2VBE04RC/17 , SA2VBE04PC/17 , SA2VBE04KW/17 , SA2VBE04WW/17 , SA2VBE04RW/17 , SA2VBE04PW/17 , SA2ARA08K/37 , SA2VBE08K/37 , SA2VBE04K/37 , SA2ARA16K/37 , SA2ARA16S/17 , SA2VBE08S/17 , SA2ARA08K/17 , SA2VBE08K/17 , SA2ARA16K/17 , SA2VBE04K/17 . Click here to show more product numbers Click here to show less product numbers

    Contact Philips

    We are happy to help you

    Looking for something else?

    Discover all Philips Support options

    Back to top

    Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.