1
0

Shopping cart

There are currently no items in your shopping cart.

    Philips Support

    "SP" or "Service Pack" error when loading the CD supplied with my Philips player

    Published on 2017-03-01

    You need to update your operating system because it doesn’t meet the minimum operating system requirement.

    The minimum operating system requirement for this product is:

    • Windows 98SE & ME
    • Windows 2000 SP4 (or above)

    For Windows 2000 users, you will need SP4 (or above). The current link for this download is:

    • http://www.microsoft.com/windows2000/downloads

    The link may change in the future and using a search engine with the following keywords should assist you.

    • Windows 2000 Download Service Pack

    Windows XP (home or Professional) SP1 (or above)
    For Windows XP users (home or Professional) SP1 (or above) are required. The current link for this download is:

    • http://www.microsoft.com/downloads

    The link may change in the future and using a search engine with the following keywords should assist you.

    • Windows XP Download Service Pack
    Contact Philips

    We are happy to help you

    Looking for something else?

    Discover all Philips Support options

    Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.