• Free shipping

  • 2-5 business day delivery

  • 30 days return guarantee

1
0

Shopping cart

There are currently no items in your shopping cart.

    Products

    Get exactly the support you need
    Looking for specific solutions for your product?

    Does the Bluetooth version of my phone and Philips headset need to match?

    No, e.g. a headset with Bluetooth version 2.0+EDR can work with a mobile phone with Bluetooth version 1.2, although some of the advanced features of the newer Bluetooth version may not be used.

    However to work successfully both devices need to support the same profile, e.g. to stream music over Bluetooth both the headset and the mobile phone need to support A2DP.

    The information on this page applies to the following models: SHB5000WT/00 , SHB9001WT/00 , SHB6110/37 .

    Register your product
    Register your product

    Keep track of your product warranty coverage

    Qualify for cash-back, gifts and special offers

    Get easy access to product support

    Back to top
    Back to top