1
0

Shopping cart

There are currently no items in your shopping cart.

    Philips Support

    Which version of Djay 2 app is compatible with my Philips system?

    Published on 2017-02-28

    The below versions of 'djay 2' app are advised for the optimal performance of this sound system:

    • For iPad: v2.2 or above
    • For iPhone: v2.0.1 or above
    • For iPod Touch: v2.1.1 or above

    The information on this page applies to the following models: DS8900/37 .

    Looking for something else?

    Discover all Philips Support options

    Back to top

    Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.